using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\w(?=\w{4})";
string substitution = @"#";
string input = @"4f563a46jy7u35616
4f56sdfsddf
okmefiwmkiol
drejkskmilw
123434355454
34223";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}