# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\([^()]*)\(([^()]*)\)/\1{\2}/g;t' <<< "This is a (string) with lots of (brackets) and (to make ((the fun) complete) some are) even nested.
// after first replace:
This is a (string) with lots of (brackets) and (to make ({the fun} complete) some are) even nested.
foo (bar (spam) and (eggs))
foo (bar {spam} and (eggs))
foo (bar {spam} and {eggs})
foo (bar (spam (ham)) and (eggs))
foo (bar (spam {ham}) and (eggs))
foo (bar {spam {ham}} and (eggs))
foo (bar {spam {ham}} and {eggs})"