#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(\([^()]*)\(([^()]*)\)"
Local $sString = "This is a (string) with lots of (brackets) and (to make ((the fun) complete) some are) even nested." & @CRLF & _
"" & @CRLF & _
"// after first replace:" & @CRLF & _
"This is a (string) with lots of (brackets) and (to make ({the fun} complete) some are) even nested." & @CRLF & _
"" & @CRLF & _
"foo (bar (spam) and (eggs))" & @CRLF & _
"foo (bar {spam} and (eggs))" & @CRLF & _
"foo (bar {spam} and {eggs})" & @CRLF & _
"" & @CRLF & _
"foo (bar (spam (ham)) and (eggs))" & @CRLF & _
"foo (bar (spam {ham}) and (eggs))" & @CRLF & _
"foo (bar {spam {ham}} and (eggs))" & @CRLF & _
"foo (bar {spam {ham}} and {eggs})"
Local $sSubst = "\1{\2}"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)