re = /(\([^()]*)\(([^()]*)\)/
str = 'This is a (string) with lots of (brackets) and (to make ((the fun) complete) some are) even nested.
// after first replace:
This is a (string) with lots of (brackets) and (to make ({the fun} complete) some are) even nested.
foo (bar (spam) and (eggs))
foo (bar {spam} and (eggs))
foo (bar {spam} and {eggs})
foo (bar (spam (ham)) and (eggs))
foo (bar (spam {ham}) and (eggs))
foo (bar {spam {ham}} and (eggs))
foo (bar {spam {ham}} and {eggs})'
subst = '\\1{\\2}'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result