import Foundation
let pattern = #"(\([^()]*)\(([^()]*)\)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
This is a (string) with lots of (brackets) and (to make ((the fun) complete) some are) even nested.
// after first replace:
This is a (string) with lots of (brackets) and (to make ({the fun} complete) some are) even nested.
foo (bar (spam) and (eggs))
foo (bar {spam} and (eggs))
foo (bar {spam} and {eggs})
foo (bar (spam (ham)) and (eggs))
foo (bar (spam {ham}) and (eggs))
foo (bar {spam {ham}} and (eggs))
foo (bar {spam {ham}} and {eggs})
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1{\2}"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)