import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\([^()]*)\\(([^()]*)\\)";
final String string = "This is a (string) with lots of (brackets) and (to make ((the fun) complete) some are) even nested.\n\n"
+ "// after first replace:\n"
+ "This is a (string) with lots of (brackets) and (to make ({the fun} complete) some are) even nested.\n\n"
+ "foo (bar (spam) and (eggs))\n"
+ "foo (bar {spam} and (eggs))\n"
+ "foo (bar {spam} and {eggs})\n\n"
+ "foo (bar (spam (ham)) and (eggs))\n"
+ "foo (bar (spam {ham}) and (eggs))\n"
+ "foo (bar {spam {ham}} and (eggs))\n"
+ "foo (bar {spam {ham}} and {eggs})";
final String subst = "\\1{\\2}";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}