const regex = new RegExp('(\\([^()]*)\\(([^()]*)\\)', 'g')
const str = `This is a (string) with lots of (brackets) and (to make ((the fun) complete) some are) even nested.
// after first replace:
This is a (string) with lots of (brackets) and (to make ({the fun} complete) some are) even nested.
foo (bar (spam) and (eggs))
foo (bar {spam} and (eggs))
foo (bar {spam} and {eggs})
foo (bar (spam (ham)) and (eggs))
foo (bar (spam {ham}) and (eggs))
foo (bar {spam {ham}} and (eggs))
foo (bar {spam {ham}} and {eggs})`;
const subst = `\1{\2}`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);