# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\([^()]*)\(([^()]*)\)"
test_str = ("This is a (string) with lots of (brackets) and (to make ((the fun) complete) some are) even nested.\n\n"
"// after first replace:\n"
"This is a (string) with lots of (brackets) and (to make ({the fun} complete) some are) even nested.\n\n"
"foo (bar (spam) and (eggs))\n"
"foo (bar {spam} and (eggs))\n"
"foo (bar {spam} and {eggs})\n\n"
"foo (bar (spam (ham)) and (eggs))\n"
"foo (bar (spam {ham}) and (eggs))\n"
"foo (bar {spam {ham}} and (eggs))\n"
"foo (bar {spam {ham}} and {eggs})")
subst = "\\1{\\2}"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.