using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\([^()]*)\(([^()]*)\)";
string substitution = @"\1{\2}";
string input = @"This is a (string) with lots of (brackets) and (to make ((the fun) complete) some are) even nested.
// after first replace:
This is a (string) with lots of (brackets) and (to make ({the fun} complete) some are) even nested.
foo (bar (spam) and (eggs))
foo (bar {spam} and (eggs))
foo (bar {spam} and {eggs})
foo (bar (spam (ham)) and (eggs))
foo (bar (spam {ham}) and (eggs))
foo (bar {spam {ham}} and (eggs))
foo (bar {spam {ham}} and {eggs})";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}