# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/Line[23]\R//g;t' <<< "Line1
Line2
Line3
Line4"