import re
regex = re.compile(r"Line[23]\R")
test_str = ("Line1\n"
"Line2\n"
"Line3\n"
"Line4")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)