using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Line[23]\R";
string substitution = @"";
string input = @"Line1
Line2
Line3
Line4";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}