use strict;
my $str = 'Line1
Line2
Line3
Line4';
my $regex = qr/Line[23]\R/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";