#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "Line[23]\R"
Local $sString = "Line1" & @CRLF & _
"Line2" & @CRLF & _
"Line3" & @CRLF & _
"Line4"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)