#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)<tr CLASS='[^']*'>[^<]*<td CLASS='[^']*'>(.*)<\/td>[^<]*<td CLASS='[^']*'>(.*)<\/td>[^<]*<\/tr>"
Local $sString = "<tr CLASS='style12'>" & @CRLF & _
"<td CLASS='style11'>Data 1</td>" & @CRLF & _
"<td CLASS='red'><a href="#">test</a></td>" & @CRLF & _
"</tr>" & @CRLF & _
"<tr CLASS='style12'>" & @CRLF & _
"<td CLASS='style11'>Data 2</td>" & @CRLF & _
"<td CLASS='red'><a href="#">test</a></td>" & @CRLF & _
"</tr>" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")