using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<tr CLASS='[^']*'>[^<]*<td CLASS='[^']*'>(.*)<\/td>[^<]*<td CLASS='[^']*'>(.*)<\/td>[^<]*<\/tr>";
string input = @"<tr CLASS='style12'>
<td CLASS='style11'>Data 1</td>
<td CLASS='red'><a href=""#"">test</a></td>
</tr>
<tr CLASS='style12'>
<td CLASS='style11'>Data 2</td>
<td CLASS='red'><a href=""#"">test</a></td>
</tr>
";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}