package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)<tr CLASS='[^']*'>[^<]*<td CLASS='[^']*'>(.*)<\/td>[^<]*<td CLASS='[^']*'>(.*)<\/td>[^<]*<\/tr>`)
var str = `<tr CLASS='style12'>
<td CLASS='style11'>Data 1</td>
<td CLASS='red'><a href="#">test</a></td>
</tr>
<tr CLASS='style12'>
<td CLASS='style11'>Data 2</td>
<td CLASS='red'><a href="#">test</a></td>
</tr>
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}