// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)<tr CLASS='[^']*'>[^<]*<td CLASS='[^']*'>(.*)<\/td>[^<]*<td CLASS='[^']*'>(.*)<\/td>[^<]*<\/tr>").unwrap();
let string = "<tr CLASS='style12'>
<td CLASS='style11'>Data 1</td>
<td CLASS='red'><a href=\"#\">test</a></td>
</tr>
<tr CLASS='style12'>
<td CLASS='style11'>Data 2</td>
<td CLASS='red'><a href=\"#\">test</a></td>
</tr>
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}