import re
regex = re.compile(r"<tr CLASS='[^']*'>[^<]*<td CLASS='[^']*'>(.*)<\/td>[^<]*<td CLASS='[^']*'>(.*)<\/td>[^<]*<\/tr>", flags=re.IGNORECASE)
test_str = ("<tr CLASS='style12'>\n"
"<td CLASS='style11'>Data 1</td>\n"
"<td CLASS='red'><a href=\"#\">test</a></td>\n"
"</tr>\n"
"<tr CLASS='style12'>\n"
"<td CLASS='style11'>Data 2</td>\n"
"<td CLASS='red'><a href=\"#\">test</a></td>\n"
"</tr>\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")