$re = '/<tr CLASS=\'[^\']*\'>[^<]*<td CLASS=\'[^\']*\'>(.*)<\/td>[^<]*<td CLASS=\'[^\']*\'>(.*)<\/td>[^<]*<\/tr>/i';
$str = '<tr CLASS=\'style12\'>
<td CLASS=\'style11\'>Data 1</td>
<td CLASS=\'red\'><a href="#">test</a></td>
</tr>
<tr CLASS=\'style12\'>
<td CLASS=\'style11\'>Data 2</td>
<td CLASS=\'red\'><a href="#">test</a></td>
</tr>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);