const regex = /<tr CLASS='[^']*'>[^<]*<td CLASS='[^']*'>(.*)<\/td>[^<]*<td CLASS='[^']*'>(.*)<\/td>[^<]*<\/tr>/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<tr CLASS=\'[^\']*\'>[^<]*<td CLASS=\'[^\']*\'>(.*)<\\\/td>[^<]*<td CLASS=\'[^\']*\'>(.*)<\\\/td>[^<]*<\\\/tr>', 'gi')
const str = `<tr CLASS='style12'>
<td CLASS='style11'>Data 1</td>
<td CLASS='red'><a href="#">test</a></td>
</tr>
<tr CLASS='style12'>
<td CLASS='style11'>Data 2</td>
<td CLASS='red'><a href="#">test</a></td>
</tr>
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}