re = /<tr CLASS='[^']*'>[^<]*<td CLASS='[^']*'>(.*)<\/td>[^<]*<td CLASS='[^']*'>(.*)<\/td>[^<]*<\/tr>/i
str = '<tr CLASS=\'style12\'>
<td CLASS=\'style11\'>Data 1</td>
<td CLASS=\'red\'><a href="#">test</a></td>
</tr>
<tr CLASS=\'style12\'>
<td CLASS=\'style11\'>Data 2</td>
<td CLASS=\'red\'><a href="#">test</a></td>
</tr>
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end