using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:^|\n)(?: *\n*)*,* *([^ \n,]+) [^\n]*";
string substitution = @"CASE typeof($1) WHEN 'text' THEN ""'"" || REPLACE($1,""'"",""''"") || ""'"" WHEN 'null' THEN 'null' WHEN 'blob' THEN 'blob??' ELSE $1 END\n ||','|| ";
string input = @"_id INTEGER PRIMARY KEY AUTOINCREMENT
, _id_task INTEGER NOT NULL
, _period INTEGER NOT NULL
, checksDone INTEGER NOT NULL
, secondsDone INTEGER NOT NULL
, timerStartDate DATETIME ";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}