// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?:^|\n)(?: *\n*)*,* *([^ \n,]+) [^\n]*").unwrap();
let string = "_id INTEGER PRIMARY KEY AUTOINCREMENT
, _id_task INTEGER NOT NULL
, _period INTEGER NOT NULL
, checksDone INTEGER NOT NULL
, secondsDone INTEGER NOT NULL
, timerStartDate DATETIME ";
let substitution = "CASE typeof($1) WHEN 'text' THEN \"'\" || REPLACE($1,\"'\",\"''\") || \"'\" WHEN 'null' THEN 'null' WHEN 'blob' THEN 'blob??' ELSE $1 END\\n ||','|| ";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}