re = /(?:^|\n)(?: *\n*)*,* *([^ \n,]+) [^\n]*/
str = '_id INTEGER PRIMARY KEY AUTOINCREMENT
, _id_task INTEGER NOT NULL
, _period INTEGER NOT NULL
, checksDone INTEGER NOT NULL
, secondsDone INTEGER NOT NULL
, timerStartDate DATETIME '
subst = 'CASE typeof($1) WHEN \'text\' THEN "\'" || REPLACE($1,"\'","\'\'") || "\'" WHEN \'null\' THEN \'null\' WHEN \'blob\' THEN \'blob??\' ELSE $1 END\\n ||\',\'|| '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result