package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:^|\n)(?: *\n*)*,* *([^ \n,]+) [^\n]*`)
var str = `_id INTEGER PRIMARY KEY AUTOINCREMENT
, _id_task INTEGER NOT NULL
, _period INTEGER NOT NULL
, checksDone INTEGER NOT NULL
, secondsDone INTEGER NOT NULL
, timerStartDate DATETIME `
var substitution = "CASE typeof($1) WHEN 'text' THEN "'" || REPLACE($1,"'","''") || "'" WHEN 'null' THEN 'null' WHEN 'blob' THEN 'blob??' ELSE $1 END\n ||','|| "
fmt.Println(re.ReplaceAllString(str, substitution))
}