import Foundation
let pattern = #"(?:^|\n)(?: *\n*)*,* *([^ \n,]+) [^\n]*"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
_id INTEGER PRIMARY KEY AUTOINCREMENT
, _id_task INTEGER NOT NULL
, _period INTEGER NOT NULL
, checksDone INTEGER NOT NULL
, secondsDone INTEGER NOT NULL
, timerStartDate DATETIME
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"CASE typeof($1) WHEN 'text' THEN "'" || REPLACE($1,"'","''") || "'" WHEN 'null' THEN 'null' WHEN 'blob' THEN 'blob??' ELSE $1 END\n ||','|| "#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)