use strict;
my $str = '_id INTEGER PRIMARY KEY AUTOINCREMENT
, _id_task INTEGER NOT NULL
, _period INTEGER NOT NULL
, checksDone INTEGER NOT NULL
, secondsDone INTEGER NOT NULL
, timerStartDate DATETIME ';
my $regex = qr/(?:^|\n)(?: *\n*)*,* *([^ \n,]+) [^\n]*/p;
my $subst = 'CASE typeof($1) WHEN \'text\' THEN "\'" || REPLACE($1,"\'","\'\'") || "\'" WHEN \'null\' THEN \'null\' WHEN \'blob\' THEN \'blob??\' ELSE $1 END\\n ||\',\'|| ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";