# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:^|\n)(?: *\n*)*,* *([^ \n,]+) [^\n]*"
test_str = ("_id INTEGER PRIMARY KEY AUTOINCREMENT\n"
", _id_task INTEGER NOT NULL\n"
", _period INTEGER NOT NULL\n"
", checksDone INTEGER NOT NULL\n"
", secondsDone INTEGER NOT NULL\n"
", timerStartDate DATETIME ")
subst = "CASE typeof($1) WHEN 'text' THEN \"'\" || REPLACE($1,\"'\",\"''\") || \"'\" WHEN 'null' THEN 'null' WHEN 'blob' THEN 'blob??' ELSE $1 END\\n ||','|| "
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.