# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^.*?\((\d{4})(?:\/[^)]*)?\).*/\1/gm;t' <<< "\"You Are There\" (1953) {The Death of Socrates (399 B.C.) (#1.14)}
Þegar það gerist (1998/I) (TV)
Johannes Passion, BWV. 245 (1725 Version) (1996) (V)"