re = /^.*?\((\d{4})(?:\/[^)]*)?\).*/m
str = '"You Are There" (1953) {The Death of Socrates (399 B.C.) (#1.14)}
Þegar það gerist (1998/I) (TV)
Johannes Passion, BWV. 245 (1725 Version) (1996) (V)'
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result