use strict;
my $str = '"You Are There" (1953) {The Death of Socrates (399 B.C.) (#1.14)}
Þegar það gerist (1998/I) (TV)
Johannes Passion, BWV. 245 (1725 Version) (1996) (V)';
my $regex = qr~^.*?\((\d{4})(?:/[^)]*)?\).*~mp;
my $subst = '\\1';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";