package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^.*?\((\d{4})(?:/[^)]*)?\).*`)
var str = `"You Are There" (1953) {The Death of Socrates (399 B.C.) (#1.14)}
Þegar það gerist (1998/I) (TV)
Johannes Passion, BWV. 245 (1725 Version) (1996) (V)`
var substitution = "\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}