import re
regex = re.compile(r"^.*?\((\d{4})(?:/[^)]*)?\).*", flags=re.MULTILINE)
test_str = ("\"You Are There\" (1953) {The Death of Socrates (399 B.C.) (#1.14)}\n"
"Þegar það gerist (1998/I) (TV)\n"
"Johannes Passion, BWV. 245 (1725 Version) (1996) (V)")
subst = "\\1"
result = regex.sub(subst, test_str)
if result:
print(result)