using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.*?\((\d{4})(?:/[^)]*)?\).*";
string substitution = @"\1";
string input = @"""You Are There"" (1953) {The Death of Socrates (399 B.C.) (#1.14)}
Þegar það gerist (1998/I) (TV)
Johannes Passion, BWV. 245 (1725 Version) (1996) (V)";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}