// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^.*?\((\d{4})(?:/[^)]*)?\).*").unwrap();
let string = "\"You Are There\" (1953) {The Death of Socrates (399 B.C.) (#1.14)}
Þegar það gerist (1998/I) (TV)
Johannes Passion, BWV. 245 (1725 Version) (1996) (V)";
let substitution = "\\1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}