#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^.*?\((\d{4})(?:/[^)]*)?\).*"
Local $sString = ""You Are There" (1953) {The Death of Socrates (399 B.C.) (#1.14)}" & @CRLF & _
"Þegar það gerist (1998/I) (TV)" & @CRLF & _
"Johannes Passion, BWV. 245 (1725 Version) (1996) (V)"
Local $sSubst = "\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)