# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[^א-ת ]//gm;t' <<< "data = [
{
\"timestamp\":[3249, 2455],
\"text\" : \"המחשבה בדבר\"
},
{
\"timestamp\":[3269, 1455],
\"text\" : \"המחשבה האמיתית\"
},
{
\"timestamp\":[234, 24423342555],
\"text\" : \"היא מחתימה את הכל \"
},
{
\"timestamp\":[3249, 2455],
\"text\" : \"עבור מישהו12 \"
}
]"