# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"[^א-ת ]"
test_str = ("data = [\n"
" {\n"
" \"timestamp\":[3249, 2455],\n"
" \"text\" : \"המחשבה בדבר\"\n"
" },\n"
" {\n"
" \"timestamp\":[3269, 1455],\n"
" \"text\" : \"המחשבה האמיתית\"\n"
" },\n"
" {\n"
" \"timestamp\":[234, 24423342555],\n"
" \"text\" : \"היא מחתימה את הכל \"\n"
" },\n"
" {\n"
" \"timestamp\":[3249, 2455],\n"
" \"text\" : \"עבור מישהו12 \"\n"
" }\n"
"]")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.