const regex = /[^א-ת ]/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[^א-ת ]', 'gm')
const str = `data = [
{
"timestamp":[3249, 2455],
"text" : "המחשבה בדבר"
},
{
"timestamp":[3269, 1455],
"text" : "המחשבה האמיתית"
},
{
"timestamp":[234, 24423342555],
"text" : "היא מחתימה את הכל "
},
{
"timestamp":[3249, 2455],
"text" : "עבור מישהו12 "
}
]`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);