#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)[^א-ת ]"
Local $sString = "data = [" & @CRLF & _
" {" & @CRLF & _
" "timestamp":[3249, 2455]," & @CRLF & _
" "text" : "המחשבה בדבר"" & @CRLF & _
" }," & @CRLF & _
" {" & @CRLF & _
" "timestamp":[3269, 1455]," & @CRLF & _
" "text" : "המחשבה האמיתית"" & @CRLF & _
" }," & @CRLF & _
" {" & @CRLF & _
" "timestamp":[234, 24423342555]," & @CRLF & _
" "text" : "היא מחתימה את הכל "" & @CRLF & _
" }," & @CRLF & _
" {" & @CRLF & _
" "timestamp":[3249, 2455]," & @CRLF & _
" "text" : "עבור מישהו12 "" & @CRLF & _
" }" & @CRLF & _
"]"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)