use strict;
my $str = 'data = [
{
"timestamp":[3249, 2455],
"text" : "המחשבה בדבר"
},
{
"timestamp":[3269, 1455],
"text" : "המחשבה האמיתית"
},
{
"timestamp":[234, 24423342555],
"text" : "היא מחתימה את הכל "
},
{
"timestamp":[3249, 2455],
"text" : "עבור מישהו12 "
}
]';
my $regex = qr/[^א-ת ]/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";