import Foundation
let pattern = #"[^א-ת ]"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
data = [
{
"timestamp":[3249, 2455],
"text" : "המחשבה בדבר"
},
{
"timestamp":[3269, 1455],
"text" : "המחשבה האמיתית"
},
{
"timestamp":[234, 24423342555],
"text" : "היא מחתימה את הכל "
},
{
"timestamp":[3249, 2455],
"text" : "עבור מישהו12 "
}
]
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)