using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^א-ת ]";
string substitution = @"";
string input = @"data = [
{
""timestamp"":[3249, 2455],
""text"" : ""המחשבה בדבר""
},
{
""timestamp"":[3269, 1455],
""text"" : ""המחשבה האמיתית""
},
{
""timestamp"":[234, 24423342555],
""text"" : ""היא מחתימה את הכל ""
},
{
""timestamp"":[3249, 2455],
""text"" : ""עבור מישהו12 ""
}
]";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}