re = /[^א-ת ]/m
str = 'data = [
{
"timestamp":[3249, 2455],
"text" : "המחשבה בדבר"
},
{
"timestamp":[3269, 1455],
"text" : "המחשבה האמיתית"
},
{
"timestamp":[234, 24423342555],
"text" : "היא מחתימה את הכל "
},
{
"timestamp":[3249, 2455],
"text" : "עבור מישהו12 "
}
]'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result