// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[^א-ת ]").unwrap();
let string = "data = [
{
\"timestamp\":[3249, 2455],
\"text\" : \"המחשבה בדבר\"
},
{
\"timestamp\":[3269, 1455],
\"text\" : \"המחשבה האמיתית\"
},
{
\"timestamp\":[234, 24423342555],
\"text\" : \"היא מחתימה את הכל \"
},
{
\"timestamp\":[3249, 2455],
\"text\" : \"עבור מישהו12 \"
}
]";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}