# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^.* ((?:([12])|(3)|([45]))\d{4}) .*/(?2AAA:(?3BBB:XYZ))$1/gm;t' <<< "Blah 12345 Blah
Blah 22345 Blah
Blah 32345 Blah
Blah 42345 Blah
Blah 52345 Blah"