# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^.* ((?:([12])|(3)|([45]))\d{4}) .*"
test_str = ("Blah 12345 Blah\n"
"Blah 22345 Blah\n"
"Blah 32345 Blah\n"
"Blah 42345 Blah\n"
"Blah 52345 Blah")
subst = "(?2AAA:(?3BBB:XYZ))$1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.