use strict;
my $str = 'Blah 12345 Blah
Blah 22345 Blah
Blah 32345 Blah
Blah 42345 Blah
Blah 52345 Blah';
my $regex = qr/^.* ((?:([12])|(3)|([45]))\d{4}) .*/mp;
my $subst = '(?2AAA:(?3BBB:XYZ))$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";