import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^.* ((?:([12])|(3)|([45]))\\d{4}) .*";
final String string = "Blah 12345 Blah\n"
+ "Blah 22345 Blah\n"
+ "Blah 32345 Blah\n"
+ "Blah 42345 Blah\n"
+ "Blah 52345 Blah";
final String subst = "(?2AAA:(?3BBB:XYZ))$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}